YNAB Status

Welcome, YNABer!

Here’s what we know right now about any financial institutions with widespread issues (learn more about these Watchlist Institutions). If your bank lands on this page, there’s no need to hug the stress pillow. Just subscribe for updates and you’ll be the first to know!

Amex UK - Unable to link account after updating connection
Incident Report for YNAB
Resolved
After monitoring Amex UK's connection for the past few days, we’ve confirmed that the issue is resolved. Follow the instructions in the last update if you have any trouble. Thank you for your patience on this one!
Posted Apr 03, 2023 - 13:49 UTC
Monitoring
The Update issue with Amex UK has been resolved! Follow the prompts to update the connection, or remove and re-add the connection if you're still running into issues. We’ll continue to monitor the situation for the next few days, but if you need more help, write in to [email protected]!
Posted Mar 29, 2023 - 21:14 UTC
Update
We've heard some good news from TrueLayer, who says that Amex is close to deploying the fix for this issue. Once the fix is confirmed we will let you all know when to try again. Thanks so much for your patience!
Posted Mar 06, 2023 - 14:28 UTC
Update
Truelayer is continuing to work behind the scenes with Amex, although we don't have an actionable update to share. Thanks for hanging in there with us on this!
Posted Feb 22, 2023 - 01:45 UTC
Update
Still no word from Amex, but we can only assume they are continuing to work on a fix for this issue. Thank you for your patience and understanding!
Posted Feb 14, 2023 - 15:02 UTC
Update
Our provider (TrueLayer) is working with Amex on this fix, and they asked Amex for an update this morning. As soon as they let us know what they heard back, we'll update here. Again, thanks for hanging in there with us! Continue to use our other transaction entry methods to keep your budget updated.
Posted Feb 06, 2023 - 17:56 UTC
Update
We just got an update from American Express last night, and they let us know that their engineering team is actively looking at having the issue fixed as soon as possible. They found the root cause that the issue is stemming from, and are now waiting on confirmation from another team in order to proceed with the fix.

Thank you all for hanging in there with us.
Posted Jan 31, 2023 - 16:52 UTC
Update
American Express is still working on the fix, but we're getting closer! We'll update here as soon as we hear anything more.
Posted Jan 26, 2023 - 00:38 UTC
Update
Amex UK has identified the issue on their end, and they've lined up the work for the fix. It looks like the currency code is missing from some of the transaction data in their API, which is what's causing the initial request of transactions to fail (and therefore causing the error message in YNAB). We expect to hear more good news in the coming week, and we'll of course to keep you updated as we learn more.
Posted Jan 19, 2023 - 14:55 UTC
Identified
TrueLayer has identified the root cause of this issue, which occurs when YNAB tries to fetch recent transactions. They are working with Amex UK directly in order to resolve the issue in their API, and we'll continue to keep you updated as things progress! Continue to use our other transaction entry methods to keep your budget updated.
Posted Jan 16, 2023 - 21:08 UTC
Investigating
We are investigating a spike in connection issues with Amex UK, so if you're having trouble linking your account after the recent prompts, please know we're on the case! We're working with TrueLayer to learn more, and we'll post updates here as we have them. In the meantime, use our other transaction entry methods to keep your budget up to date!
Posted Jan 14, 2023 - 16:12 UTC
This incident affected: Direct Import Providers (TrueLayer).